[lsc-users] Suspicious URL:Re: Execute Plugin

Braun, Thomas [Wekal] Thomas.Braun at wekal.de
Tue Nov 8 08:11:27 CET 2016


Hello Clément,

But now I stuck at this Second-Run-Problem:
I want to Sync from an Outlook Contacts CSV Export, with their default columns into an OpenLDAP 2.4.40.
My Pivotfield is uid.
My List-Script, based on your examples, generates an output in this form:

dn: uid=GivennameSurnameCompany, ou=Contacts ,dc=my, dc=domain
uid: GivennameSurnameCompany, ou=Contacts, dc=my, dc=domain

The problem seems to be here, the uid value should just be GivennameSurnameCompany.

OK, I tried this. I guess I tried all combinations. But please let us isolate together.

Now my List Output is:
dn: uid=GivennameSurnameCompany, ou=Contacts ,dc=my, dc=domain
uid: GivennameSurnameCompany



And the Get Output is:
dn: uid=GivennameSurnameCompany, ou=Contacts, dc=my, dc=domain
uid: GivennameSurnameCompany
givenName: Givenname
sn: Surname
o: Company
mobile: +1234567
cn: GivennameSurnameCompany
displayName: Surname, Givenname [Company]



An Export of the first run is:



dn: uid= GivennameSurnameCompany, ou=Contacts, dc=my, dc=domain

objectClass: top

objectClass: person

objectClass: organizationalPerson

objectClass: inetOrgPerson

cn: GivennameSurnameCompany

sn: Surname

displayName: Surname,Givenname [Company]

givenName: Givenname

o: Company

uid: GivennameSurnameCompany



Debug Output of the second run is:



Nov 08 06:59:56 - DEBUG - Lauching '/etc/lsc/scripts/lsc-executable-csv2ldif-get.pl uid= GivennameSurnameCompany, ou=Contacts, dc=my, dc=domain '

Nov 08 06:59:56 - DEBUG - Writing to STDIN uid: GivennameSurnameCompany

Nov 08 06:59:56 - DEBUG - Waiting for command to stop ...

Nov 08 06:59:59 - DEBUG - Messages dump on stderr by script:

Nov 08 06:59:59 - WARN  - WARNING: updating the RDN of the entry will cancel other modifications! Relaunch synchronization to complete update.

Nov 08 06:59:59 - INFO  - # Renaming object uid=GivennameSurnameCompany,ou=Contacts,dc=my,dc=domain for CSVSyncTask

# Tue Nov 08 06:59:59 UTC 2016

dn: uid=GivennameSurnameCompany,ou=Contacts,dc=my,dc=domain

changetype: modrdn

newrdn: uid= GivennameSurnameCompany

deleteoldrdn: 1

newsuperior: ou=Contacts,dc=my,dc=domain



Could it be the spaces in the DN?



Regards,

Thomas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lsc-project.org/pipermail/lsc-users/attachments/20161108/5a9d1d3c/attachment.htm>


More information about the lsc-users mailing list